<!DOCTYPE html>
<html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.gizmochina.com/xmlrpc.php">
<title>Meizu 16T (Turbo) gaming-focused phone to debut with Meizu 16s, 16s Plus this year - Gizmochina</title>


<link rel="canonical" href="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Meizu 16T (Turbo) gaming-focused phone to debut with Meizu 16s, 16s Plus this year - Gizmochina" />
<meta property="og:description" content="Meizu 16 series which includes Snapdragon 845 powered Meizu 16th and Meizu 16th Plus smartphones were introduced in China in August 2018. Meizu CEO Jack Wong who has been vocal..." />
<meta property="og:url" content="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/" />
<meta property="og:site_name" content="Gizmochina" />
<meta property="article:publisher" content="https://www.facebook.com/gizmochinablog" />
<meta property="article:author" content="https://www.facebook.com/zionsanvin" />
<meta property="article:tag" content="Meizu" />
<meta property="article:tag" content="Meizu 16s" />
<meta property="article:tag" content="Meizu 16s Plus" />
<meta property="article:tag" content="Meizu 16T" />
<meta property="article:tag" content="Snapdragon 855" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-01-16T03:44:09+00:00" />
<meta property="article:modified_time" content="2019-01-16T03:44:27+00:00" />
<meta property="og:updated_time" content="2019-01-16T03:44:27+00:00" />
<meta property="og:image" content="https://www.gizmochina.com/wp-content/uploads/2019/01/meizu-16s-render-featured.jpg" />
<meta property="og:image:secure_url" content="https://www.gizmochina.com/wp-content/uploads/2019/01/meizu-16s-render-featured.jpg" />
<meta property="og:image:width" content="720" />
<meta property="og:image:height" content="420" />
<meta property="og:image:alt" content="meizu-16s-render-featured" />

<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//apis.google.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Feed" href="https://www.gizmochina.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Comments Feed" href="https://www.gizmochina.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Meizu 16T (Turbo) gaming-focused phone to debut with Meizu 16s, 16s Plus this year Comments Feed" href="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.gizmochina.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.gizmochina.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='fvp-frontend-css' href='https://www.gizmochina.com/wp-content/plugins/featured-video-plus/styles/frontend.css?ver=2.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='yop-public-css' href='https://www.gizmochina.com/wp-content/plugins/yop-poll/public/assets/css/yop-poll-public.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='twitter-bootstrap-css' href='https://www.gizmochina.com/wp-content/themes/admag/css/plugins/bootstrap/css/bootstrap.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='chld_thm_cfg_parent-css' href='https://www.gizmochina.com/wp-content/themes/admag/style.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href='https://www.gizmochina.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=4.8.0.101' type='text/css' media='screen' />
<link rel='stylesheet' id='dt-style-css' href='https://www.gizmochina.com/wp-content/themes/admag-child/style.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css' href='https://www.gizmochina.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css' href='https://www.gizmochina.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.2.4' type='text/css' media='all' />
<link rel='stylesheet' id='aps-styles-css' href='https://www.gizmochina.com/wp-content/plugins/aps-products/css/aps-styles.css?ver=2.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='nivo-lightbox-css' href='https://www.gizmochina.com/wp-content/plugins/aps-products/css/nivo-lightbox.css?ver=2.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css' href='https://www.gizmochina.com/wp-content/plugins/aps-products/css/owl-carousel.css?ver=2.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css' href='https://www.gizmochina.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css' href='https://www.gizmochina.com/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=12.2' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
</style>
<script type='text/javascript' src='https://www.gizmochina.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/featured-video-plus/js/jquery.fitvids.min.js?ver=master-2015-08'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var fvpdata = {"ajaxurl":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","nonce":"ef23f49b48","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/featured-video-plus/js/frontend.min.js?ver=2.3.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var objectL10n = {"yopPollParams":{"urlParams":{"ajax":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","wpLogin":"https:\/\/www.gizmochina.com\/wp-login.php?redirect_to=https%3A%2F%2Fwww.gizmochina.com%2Fwp-admin%2Fadmin-ajax.php%3Faction%3Dyop_poll_record_wordpress_vote"},"apiParams":{"reCaptcha":{"siteKey":""},"facebook":{"appId":""},"google":{"apiKey":"","clientId":""}},"captchaParams":{"imgPath":"https:\/\/www.gizmochina.com\/wp-content\/plugins\/yop-poll\/public\/assets\/img\/","url":"https:\/\/www.gizmochina.com\/wp-content\/plugins\/yop-poll\/app.php","accessibilityAlt":"Sound icon","accessibilityTitle":"Accessibility option: listen to a question and answer it!","accessibilityDescription":"Type below the <strong>answer<\/strong> to what you hear. Numbers or words:","explanation":"Click or touch the <strong>ANSWER<\/strong>","refreshAlt":"Refresh\/reload icon","refreshTitle":"Refresh\/reload: get new images and accessibility option!"},"voteParams":{"invalidPoll":"Invalid Poll","noAnswersSelected":"No answer selected","minAnswersRequired":"At least {min_answers_allowed} answer(s) required","maxAnswersRequired":"A max of {max_answers_allowed} answer(s) accepted","noAnswerForOther":"No other answer entered","noValueForCustomField":"{custom_field_name} is required","consentNotChecked":"You must agree to our terms and conditions","noCaptchaSelected":"Captcha is required","thankYou":"Thank you for your vote"},"resultsParams":{"singleVote":"vote","multipleVotes":"votes"}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/yop-poll/public/assets/js/yop-poll-public.min.js?ver=4.9.7'></script>
<script type='text/javascript' async defer src='https://www.google.com/recaptcha/api.js?render=explicit&onload=YOPPollOnLoadRecaptcha'></script>
<script type='text/javascript' src='https://apis.google.com/js/platform.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","security":"1b24eb27c3","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/www.gizmochina.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"12.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=12.2'></script>
<link rel='https://api.w.org/' href='https://www.gizmochina.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gizmochina.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gizmochina.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.7" />
<link rel='shortlink' href='https://www.gizmochina.com/?p=232559' />
<link rel="alternate" type="application/json+oembed" href="https://www.gizmochina.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gizmochina.com%2F2019%2F01%2F16%2Fmeizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.gizmochina.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gizmochina.com%2F2019%2F01%2F16%2Fmeizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year%2F&#038;format=xml" />
<style type="text/css">.logo img{height: 42px;}.mid-logo-wrapper .logo img{height: 90px;}body,p,code, kbd, pre, samp{font-size: 18px;line-height: 24px;}.mega-menu .dropdown-menu > li > a:hover, 

.mega-menu .dropdown-submenu:hover>a,

.star-reviews,

.post-content a,

a,

.dropdown-menu .mega-menu-news .mega-menu-detail h4 a:hover,

.nav .tabs-left > .nav-tabs > li > a:hover, 

.nav .tabs-left > .nav-tabs > li.active > a,

.navbar-nav>li>a:hover, 

.navbar-nav>li>a:focus, 

.dropdown-menu>.active>a,

.navbar-nav>li.open>a, 

.navbar-nav>li.open>a:after,

.widget-content li h3 a:hover, 

.news-title a:hover, 

.small-article h6 a:hover,

.simple-post h3 a:hover, 

.widget-post h3 a:hover,

.widget_categories li a:hover, 

.widget_categories li a:hover span, 

.comments-wrapper .comment-reply-link, 

.post-header .simple-share a, 

.parallax-wrapper .simple-share a,

.drop-caps,

.author-position,

.simple-share .author a,

.simple-share .author a:hover,

.box-news .simple-share a,

.box-news .simple-share a:hover,

.post-nav-wrapper a:hover,

.author-box .author-info h3 a:hover,

.author-contact a:hover,

.comments-wrapper .author-name:hover,

.post-header .simple-share a:hover, 

.post-header .simple-share a:focus, 

.parallax-wrapper .simple-share a:hover, 

.parallax-wrapper .simple-share a:focus,

.tag-list li.trending{color: #fe0002}.progress-bar,.progress-bar, .tags-widget li a:hover, .tagcloud a:hover, .tag-list li a:hover, .tag-list li.active a{background-color: #fe0002}.mega-menu .dropdown-submenu:hover>a:after,

.nav .tabs-left > .nav-tabs > li.active>a:after{border-left-color: #fe0002}.widget .nav-tabs>li.active>a, 

.widget .nav-tabs>li.active>a:focus, 

.widget .nav-tabs>li.active>a:hover,

.block-title span,

.comments-wrapper .comment-reply-link:hover,

.modern-quote,

.box-news .simple-share a:hover,

.simple-share .author a:hover,

.post-header .simple-share a:hover, 

.post-header .simple-share a:focus, 

.parallax-wrapper .simple-share a:hover, 

.parallax-wrapper .simple-share a:focus,

.progress-bar, .tags-widget li a:hover, .tagcloud a:hover{border-color: #fe0002}.navbar-nav>li>a{font-size: 18px;line-height: 24px;}.mega-menu .dropdown-menu>li, .dropdown-menu>li>a, .mega-menu .nav-tabs>li>a{font-size: 14px;line-height: 20px;}.block-title, .comment-reply-title, .widget .nav-tabs>li>a,.widget .nav-tabs>li, .wpb_heading, .widgettitle, .footer-title{font-size: 22px;line-height: 29px;}.mm-listview>li>a{font-size: 14px;}.h1, h1{font-size: 40px;line-height: 40px;}.h2, h2{font-size: 19px;line-height: 24px;}.h3, h3{font-size: 24px;line-height: 32px;}.h4, h4{font-size: 18px;line-height: 23px;}.h5, h5{font-size: 17px;line-height: 25px;}.h6, h6{font-size: 17px;line-height: 23px;}.post-title{font-size: 38px;line-height: 40px;}.parallax-wrapper .post-title{font-size: 40px;line-height: 42px;}.post-content{max-width: 890px}</style>
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress." />
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.gizmochina.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.gizmochina.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--> <meta name="onesignal" content="wordpress-plugin" />
<link rel="manifest" href="https://www.gizmochina.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.gizmochina.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '9c879e43-e94e-4a93-8f9a-1d63a3e99772';
oneSignal_options['autoRegister'] = false;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://www.gizmochina.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['promptOptions'] = { };
              oneSignal_options['autoRegister'] = false;
              OneSignal.showHttpPrompt();
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="shortcut icon" href="https://www.gizmochina.com/wp-content/uploads/2016/03/gizmochina-profile-2.png" type="image/x-icon" /><style type="text/css">/* open-sans-regular - latin */ @font-face { font-family: 'Open Sans'; font-style: normal; font-weight: 400; src: local('Open Sans'), local('OpenSans'), url('https://www.gizmochina.com/fonts/open-sans-v13-latin-regular.woff2') format('woff2'), /* Chrome 26+, Opera 23+, Firefox 39+ */ url('https://www.gizmochina.com/fonts/open-sans-v13-latin-regular.woff') format('woff'); /* Chrome 6+, Firefox 3.6+, IE 9+, Safari 5.1+ */ } /* open-sans-800 - latin */ @font-face { font-family: 'Open Sans'; font-style: normal; font-weight: 800; src: local('Open Sans Extrabold'), local('OpenSans-Extrabold'), url('https://www.gizmochina.com/fonts/open-sans-v13-latin-800.woff2') format('woff2'), /* Chrome 26+, Opera 23+, Firefox 39+ */ url('https://www.gizmochina.com/fonts/open-sans-v13-latin-800.woff') format('woff'); /* Chrome 6+, Firefox 3.6+, IE 9+, Safari 5.1+ */ }</style><script type="text/javascript">

      /* <![CDATA[ */var ajaxurl = "https://www.gizmochina.com/wp-admin/admin-ajax.php";var dt_path = "https://www.gizmochina.com/wp-content/themes/admag";var dt_paginated_blocks = [];var dt_paginated_blocks_type = [];var dt_paginated_blocks_items = [];/* ]]> */

      </script><style type="text/css" title="dynamic-css" class="options-output">body{background-color:#ffffff;}.main-content, .news-details, .theiaStickySidebar{background-color:#ffffff;}.header-wrapper, .header-mid{background-color:#ffffff;}.header, .no-js .sb-search .sb-icon-search{background-color:#ffffff;}.header-top{background-color:#545454;}.sticky-sidebar{background-color:#FFFFFF;}.footer{background-color:#373737;}.footer-bottom{background-color:#2c2c2c;}.logo{margin-top:7px;margin-right:15px;margin-bottom:0;margin-left:0;}.mid-logo-wrapper .logo{margin-top:25px;margin-right:0;margin-bottom:0;margin-left:0;}html,body,.post-review-text,code, kbd, pre, samp{font-family:"Open Sans";text-transform:none;font-weight:400;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading html,body,.post-review-text,code, kbd, pre, samp,{opacity: 0;}.ie.wf-loading html,body,.post-review-text,code, kbd, pre, samp,{visibility: hidden;}h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6{font-family:Roboto;text-transform:none;font-weight:500;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6,{visibility: hidden;}.widget-post h3, .tag-list li, .dropdown-menu .mega-menu-news .mega-menu-detail h4{font-family:Roboto;text-transform:none;font-weight:300;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .widget-post h3, .tag-list li, .dropdown-menu .mega-menu-news .mega-menu-detail h4,{opacity: 0;}.ie.wf-loading .widget-post h3, .tag-list li, .dropdown-menu .mega-menu-news .mega-menu-detail h4,{visibility: hidden;}.featured-header h2, .page-subtitle{font-family:Roboto;text-transform:none;font-weight:700;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .featured-header h2, .page-subtitle,{opacity: 0;}.ie.wf-loading .featured-header h2, .page-subtitle,{visibility: hidden;}.block-title, .comment-reply-title, .widget .nav-tabs>li>a, .wpb_heading, .widgettitle, .footer-title{font-family:Roboto;text-transform:none;font-weight:700;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .block-title, .comment-reply-title, .widget .nav-tabs>li>a, .wpb_heading, .widgettitle, .footer-title,{opacity: 0;}.ie.wf-loading .block-title, .comment-reply-title, .widget .nav-tabs>li>a, .wpb_heading, .widgettitle, .footer-title,{visibility: hidden;}.mega-menu .navbar-nav>li>a,.mm-listview a, .mega-menu .nav-tabs>li>a, .header-top .top-menu li, .mega-menu .nav, .mega-menu .collapse, .mega-menu .dropdown{font-family:Roboto;text-transform:none;font-weight:500;font-style:normal;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading .mega-menu .navbar-nav>li>a,.mm-listview a, .mega-menu .nav-tabs>li>a, .header-top .top-menu li, .mega-menu .nav, .mega-menu .collapse, .mega-menu .dropdown,{opacity: 0;}.ie.wf-loading .mega-menu .navbar-nav>li>a,.mm-listview a, .mega-menu .nav-tabs>li>a, .header-top .top-menu li, .mega-menu .nav, .mega-menu .collapse, .mega-menu .dropdown,{visibility: hidden;}</style><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="post-template-default single single-post postid-232559 single-format-standard sticky-header wide wpb-js-composer js-comp-ver-4.8.0.101 vc_responsive">
<div id="fb-root"></div>

<div id="main">
<header class="header-wrapper clearfix">
<div class="header" id="header">
<div class="container">
<div class="mag-content">
<div class="row">
<div class="col-md-12">
<a class="navbar-toggle collapsed" id="nav-button" href="#mobile-nav">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</a>
<nav class="navbar mega-menu">
<a class="logo" href="https://www.gizmochina.com/" title="Gizmochina - China Phones, Tablets , Gadgets News And Review" rel="home">
<img src="https://www.gizmochina.com/wp-content/uploads/2018/11/logo_2018.png" alt="Gizmochina" />
</a>
<div id="main-nav" class="collapse navbar-collapse"><ul id="menu-android" class="nav navbar-nav"><li id="menu-item-122067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122067"><a href="https://www.gizmochina.com/news/">News</a></li>
<li id="menu-item-122068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122068"><a href="https://www.gizmochina.com/review/">Review</a></li>
<li id="menu-item-101707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-101707 dropdown"><a href="https://www.gizmochina.com/phones/" class="dropdown-toggle" aria-haspopup="true">Phones <span class="caret"></span></a>
<ul role="menu" class="dropdown-menu">
<li id="menu-item-166848" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166848"><a href="https://www.gizmochina.com/brand/xiaomi/">Xiaomi</a></li>
<li id="menu-item-166849" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166849"><a href="https://www.gizmochina.com/brand/huawei/">Huawei</a></li>
<li id="menu-item-166850" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166850"><a href="https://www.gizmochina.com/brand/meizu/">Meizu</a></li>
<li id="menu-item-166865" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166865"><a href="https://www.gizmochina.com/brand/nubia/">nubia</a></li>
<li id="menu-item-166854" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166854"><a href="https://www.gizmochina.com/brand/oneplus/">OnePlus</a></li>
<li id="menu-item-166851" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166851"><a href="https://www.gizmochina.com/brand/oppo/">OPPO</a></li>
<li id="menu-item-166852" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166852"><a href="https://www.gizmochina.com/brand/vivo/">vivo</a></li>
<li id="menu-item-166853" class="menu-item menu-item-type-taxonomy menu-item-object-aps-brands menu-item-166853"><a href="https://www.gizmochina.com/brand/zte/">ZTE</a></li>
<li id="menu-item-166859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-166859"><a href="https://www.gizmochina.com/phones/">All</a></li>
</ul>
</li>
<li id="menu-item-122136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122136"><a href="https://www.gizmochina.com/giveaway/">Giveaway</a></li>
<li id="menu-item-117279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117279"><a href="https://www.gizmochina.com/deal/">Deals</a></li>
<li id="menu-item-51841" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51841"><a href="https://www.giztop.com/" target="_blank">Shop</a></li>
</ul></div>
<div class="header-right">
<div class="social-icons">
<a href="https://www.facebook.com/gizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook fa-lg"></i></a><a href="https://twitter.com/gizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter fa-lg"></i></a><a href="https://www.youtube.com/user/GizmoChinaTube" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube fa-lg"></i></a><a href="https://plus.google.com/106254210429868626292" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus fa-lg"></i></a><a href="https://vk.com/rugizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="VK" target="_blank"><i class="fa fa-vk fa-lg"></i></a><a href="https://www.gizmochina.com/rss" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="RSS" target="_blank"><i class="fa fa-rss fa-lg"></i></a> 
</div>
<a href="#" class="fixed-button navbar-toggle" id="fixed-button">
<i></i>
<i></i>
<i></i>
<i></i>
</a>
</div>
<div id="sb-search" class="sb-search">
<form action="https://www.gizmochina.com/" method="get">
<input class="sb-search-input" placeholder="Enter your search text..." type="text" value="" name="s" id="search">
<input class="sb-search-submit" type="submit" value="">
<input type="hidden" value="post" name="post_type" id="post_type" />
<span class="sb-icon-search fa fa-search" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Search"></span>
</form>
</div>
</nav>
</div>
</div>
</div>
</div>
</div>
</header>
<div id="content" class="site-content">

<div class="container main-wrapper">
<div class="mag-content clearfix">
<div class="row">
<div class="col-md-12">
<div class="content-top-wrapper"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-1273706541600169" data-ad-slot="1180667344" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
<div class="main-content mag-content clearfix">
<div class="row blog-content">
<div class="col-md-9 main-wp dt_content" style="padding-right:30px; max-width:910px;">
<div class="theiaStickySidebar">
<div class="row">
<div class="col-md-12">
<article id="post-232559" class="dt_post_content clearfix post-232559 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-16s tag-meizu-16s-plus tag-meizu-16t tag-snapdragon-855">
<header class="post-header">
<h1 class="post-title">Meizu 16T (Turbo) gaming-focused phone to debut with Meizu 16s, 16s Plus this year</h1>
<div class="cat-wrapper"><a href='https://www.gizmochina.com/category/meizu/' class='dt_cat bgcolor9'>Meizu</a><a href='https://www.gizmochina.com/category/news/' class='dt_cat bgcolor9'>News</a></div>
<p class="simple-share">by <span class="author vcard"><a class="url fn n" href="https://www.gizmochina.com/author/anvinraj/"><b>Anvinraj Valiyathara</b></a></span> <span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-16T03:44:09+00:00">1 min</time> ago</span><a class="comments-count" href="#comments">0</a></p>
</header>
<div class="post-content clearfix">
<div class="at-above-post addthis_tool" data-url="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/"></div><p><a href="https://www.gizmochina.com/tag/meizu'">Meizu</a> 16 series which includes Snapdragon 845 powered <a href="https://www.gizmochina.com/product/meizu-16">Meizu 16th</a> and <a href="https://www.gizmochina.com/product/meizu-16-plus/">Meizu 16th Plus</a> smartphones were introduced in China in August 2018. Meizu CEO Jack Wong who has been vocal about forthcoming smartphones has confirmed that apart from launching Snapdragon 855 chipset driven Meizu 16s and Meizu 16s Plus smartphones, the company will be also debuting the Meizu 16T gaming focused smartphone.</p>
<p><a href="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/image-5-2/" rel="attachment wp-att-232560"><img class="aligncenter size-full wp-image-232560" src="https://www.gizmochina.com/wp-content/uploads/2019/01/image-5.png" alt="Meizu 16T confirmation" width="593" height="1466" srcset="https://www.gizmochina.com/wp-content/uploads/2019/01/image-5.png 593w, https://www.gizmochina.com/wp-content/uploads/2019/01/image-5-121x300.png 121w, https://www.gizmochina.com/wp-content/uploads/2019/01/image-5-414x1024.png 414w" sizes="(max-width: 593px) 100vw, 593px" /></a></p>
<p>Last night, Wong confirmed on Weibo that apart from launching Meizu 16s and Meizu 16s Plus, there will be a new smartphone called Meizu 16G where “G” refers to “gaming.”  Some netizens responded by saying that the “16G” can easily confuse people to believe that it is a Meizu phone with 16 GB storage. Then, Wong deduced “16T” as the new for the gaming-centric smartphone. He added that the “T” in Meizu 16T refers to “Turbo.”</p>
<p>While the Meizu 16s and 16s Plus phones will be powered by Snapdragon 855, Wong confirmed that the Meizu 16T will be fueled by a different SoC. Hence, the Meizu 16T won’t be a flagship phone.</p>
<p>The Meizu 16s and 16s Plus will respectively feature 6.2-inch and 6.5-inch displays. The Meizu 16T will feature a notch-less screen, but its exact size is yet to be finalized. Meizu phones hope that it will have a 6.2-inch display. The handset feature narrow bezels around the screen and it will be powered by 4,000 to 4,500mAh capacity battery.</p>
<p>What about the appearance of the Meizu 16s series? Meizu phones have been always praised for launching phones with beautiful design. Recently, a <a href="https://www.gizmochina.com/2018/12/10/meizu-ceo-jack-wong-approves-the-beautiful-fan-made-render-of-the-meizu-16s/">fan-made render of the Meizu 16s</a> had surfaced on Meizu community forum. Meizu CEO has claimed the appearance of the Meizu 16s won’t be very different from the fan-made render. However, there is no confirmation on whether the gaming-centric Meizu 16T will be also sporting the same design.</p>
<p><a href="https://www.gizmochina.com/2018/12/10/meizu-ceo-jack-wong-approves-the-beautiful-fan-made-render-of-the-meizu-16s/meizu-2-7/" rel="attachment wp-att-226974"><img class="aligncenter size-full wp-image-226974" src="https://www.gizmochina.com/wp-content/uploads/2018/12/meizu-2.png" alt="Meizu 16s" width="594" height="568" srcset="https://www.gizmochina.com/wp-content/uploads/2018/12/meizu-2.png 594w, https://www.gizmochina.com/wp-content/uploads/2018/12/meizu-2-300x287.png 300w" sizes="(max-width: 594px) 100vw, 594px" /></a></p>
<ul>
<li><strong>Read More: <a href="https://www.gizmochina.com/2019/01/14/meizu-note-9-specs-render-leak-reveals-waterdrop-notch-screen-snapdragon-675-and-48mp-camera/">Meizu Note 9 specs, render leak reveals waterdrop notch screen, Snapdragon 675 and 48MP camera</a></strong></li>
</ul>
<p>There is no information available on the launch date of the Meizu 16s series and Meizu 16T. Probably, these phones are speculated to go official in May. The first phone from the Chinese manufacturer will be the Meizu Note 9 phone that is expected to launch with 48-megapixel camera and Snapdragon 675 chipset.</p>
<p>(<a href="https://weibo.com/u/5033090411?refer_flag=1005050003_" target="_blank" rel="nofollow">source</a>)</p>
<div class="at-below-post addthis_tool" data-url="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/"></div><div id="comments-anchor" class="spot-im-comments comments-area">
<script async data-spotim-module="spotim-launcher" data-article-tags="Meizu, Meizu 16s, Meizu 16s Plus, Meizu 16T, Snapdragon 855" src="https://launcher.spot.im/spot/sp_6NxfyvMn" data-post-id="232559" data-post-url="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/" data-short-url="https://www.gizmochina.com/?p=232559" data-messages-count="10" data-wp-import-endpoint="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/feed/spotim/" data-facebook-url="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/" data-disqus-shortname="" data-disqus-url="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/" data-disqus-identifier="232559 https://www.gizmochina.com/?p=232559" data-community-question="" data-seo-enabled="false" data-wp-v="p-4.3.0/wp-4.9.7"></script>
<div data-spotim-module="recirculation" data-spot-id="sp_6NxfyvMn"></div>
<script async src="https://recirculation.spot.im/spot/sp_6NxfyvMn" data-spotim-script="recirculation"></script>
</div>
</div>
<footer class="post-meta">
<div class="tags-wrapper"><ul class="tags-widget clearfix">
<li class="trending">Tags:</li><li><a href="https://www.gizmochina.com/tag/meizu/" rel="tag">Meizu</a></li><li><a href="https://www.gizmochina.com/tag/meizu-16s/" rel="tag">Meizu 16s</a></li><li><a href="https://www.gizmochina.com/tag/meizu-16s-plus/" rel="tag">Meizu 16s Plus</a></li><li><a href="https://www.gizmochina.com/tag/meizu-16t/" rel="tag">Meizu 16T</a></li><li><a href="https://www.gizmochina.com/tag/snapdragon-855/" rel="tag">Snapdragon 855</a></li></ul></div>
<div class="author-box clearfix">
<div class="author-avatar">
<a href="https://www.gizmochina.com/author/anvinraj/">
<img alt='' src='https://secure.gravatar.com/avatar/531216b6180090f044c67f41856e4eba?s=110&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/531216b6180090f044c67f41856e4eba?s=220&#038;d=mm&#038;r=g 2x' class='avatar avatar-110 photo' height='110' width='110' /> </a>
</div>
<div class="author-info">
<h3><a href="https://www.gizmochina.com/author/anvinraj/">Anvinraj Valiyathara</a></h3>
<p class="author-position">News Writer</p>
<p>Anvin is your guy if you want to choose a perfect smartphone in your budget. He is always abreast with the latest news on smartphones and various tech products. In his free time, he loves to visit famous tourist attractions.</p>
<div class="author-contact">
<a href="https://www.facebook.com/zionsanvin" target="_blank"><i class="fa fa-facebook fa-lg" title="Facebook"></i></a><a href="https://twitter.com/ZionsAnvin" target="_blank"><i class="fa fa-twitter fa-lg" title="Twitter"></i></a> </div>
</div>
</div>
<div class="row">
<div class="post-nav-wrapper clearfix">
<div class="col-md-6 omega">
<div class="previous-post">
<div class="post-nav-label">
<i class="fa fa-angle-left"></i>
Previous post </div>
<a href="https://www.gizmochina.com/2019/01/16/buy-chuwi-lapbook-se-laptop-for-just-268-99-on-geekbuying-coupon-inside/">Buy Chuwi Lapbook SE Laptop For Just $268.99 On GeekBuying [Coupon Inside]</a>
</div>
</div>
<div class="col-md-6 alpha">
</div>
</div>
</div>
</footer>
<div class="content-mid-wrapper clearfix"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-1273706541600169" data-ad-slot="6560359871" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="related-posts clearfix"><h3 class="block-title"><span>Related posts</span></h3><div class="row "><div class="col-md-4">
<article class="small-article post-232409 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-samsung tag-exynos-9820 tag-galaxy-s10 tag-galaxy-s10-plus tag-samsung tag-snapdragon-855">
<figure class="feed-image">
<a href="https://www.gizmochina.com/2019/01/15/samsung-galaxy-s10-s10-plus-3c-approved-china-launch-could-be-at-march-beginning/">
<img src="https://www.gizmochina.com/wp-content/uploads/2018/12/Samsung-Galaxy-S10-Plus-renders-1-540x355.png" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="Samsung Galaxy S10 Plus renders" /> </a>
</figure>
<h6>
<a href="https://www.gizmochina.com/2019/01/15/samsung-galaxy-s10-s10-plus-3c-approved-china-launch-could-be-at-march-beginning/">
Samsung Galaxy S10, S10 Plus 3C approved, China launch could be at March beginning </a>
</h6>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-15T06:39:06+00:00">21 hours</time> ago</span></p></article></div><div class="col-md-4">
<article class="small-article post-232134 post type-post status-publish format-standard has-post-thumbnail hentry category-lenovo category-news tag-lenovo tag-snapdragon-855 tag-z5-pro-gt">
<figure class="feed-image">
<a href="https://www.gizmochina.com/2019/01/14/lenovo-z5-pro-gt-release-delayed-to-january-29/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/Lenovo-Z5-Pro-GT-featured-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="Lenovo-Z5-Pro-GT-featured" /> </a>
</figure>
<h6>
<a href="https://www.gizmochina.com/2019/01/14/lenovo-z5-pro-gt-release-delayed-to-january-29/">
Lenovo Z5 Pro GT release delayed to January 29 </a>
</h6>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-14T05:09:17+00:00">2 days</time> ago</span></p></article></div><div class="col-md-4">
<article class="small-article post-232099 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-note-9">
<figure class="feed-image">
<a href="https://www.gizmochina.com/2019/01/14/meizu-note-9-specs-render-leak-reveals-waterdrop-notch-screen-snapdragon-675-and-48mp-camera/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/Meizu-Note-9-render_-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="" /> </a>
</figure>
<h6>
<a href="https://www.gizmochina.com/2019/01/14/meizu-note-9-specs-render-leak-reveals-waterdrop-notch-screen-snapdragon-675-and-48mp-camera/">
Meizu Note 9 specs, render leak reveals waterdrop notch screen, Snapdragon 675 and 48MP camera </a>
</h6>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-14T02:50:45+00:00">2 days</time> ago</span></p></article></div></div></div>
</article>
</div>
</div> </div>
</div>
<div class="w-c-r col-md-3 dt_sidebar">
<div class="widget-area" role="complementary">
<div class="theiaStickySidebar">
<aside id="aps_search-5" class="widget aps_search">
<h3 class="block-title"><span>Phone Finder</span></h3>
<form class="aps-search-form" method="get" action="https://www.gizmochina.com">
<div class="aps-search-field">
<input type="hidden" name="post_type" value="aps-products" />
<input type="text" name="s" class="aps-search" value="" />
<span class="aps-icon-search aps-search-btn"></span>
</div>
</form>
<script type="text/javascript">
			(function($) {
				$(".aps-search").each(function() {
					var sinput = $(this),
					sparent = sinput.parent(),
					oul = (!!sparent.find(".aps-ajax-results").length ? $(".aps-ajax-results") : $("<ul class='aps-ajax-results'></ul>"));
					sinput.on("input propertychange", function(e) {
						var query = sinput.val();
						if (query.length > 1) {
							$.getJSON(
								aps_vars.ajaxurl + "?action=aps-search&num=5&search=" + query,
								function(data) {
									if (data) {
										oul.empty();
										$.each(data, function(k, v) {
											oul.append(v);
										});
										oul.remove();
										sparent.append(oul);
									}
								}
							);
						} else {
							oul.empty();
						}
					}).blur(function() {
						setTimeout(function() {
							oul.hide();
						}, 500);
					}).focus(function() {
						oul.show();
					});
					
					/* submit form on click */
					$(".aps-search-btn").click(function() {
						sinput.parents(".aps-search-form").trigger("submit");
					});
				});
			})(jQuery);
			</script>
</aside>
<aside id="boxed_widget-4" class="widget widget_boxed_widget"><div align=center><a href="https://goo.gl/fMnvPA" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2018/12/giztop-mate20x.jpg" style="width: 300px; height: 438px;" /></a>
</div>
<p></br></p>
<div align=center><a href="https://goo.gl/H6rQ82" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2019/01/blackview-b0107b.gif" style="width: 300px; height: 250px;" /></a>
</div>
<p></br></p>
<div align=center><a href="http://www.sunsky-online.com/en/s/Q7zU3q" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2019/01/sunsky-b0115.gif" style="width: 300px; height: 250px;" /></a>
</div></aside><aside id="tabs_widget-2" class="widget widget_tabs_widget"> <ul class="nav nav-tabs" role="tablist" id="widget-tab">
<li role="presentation" class="active"><a href="#dtblockee32d08691a4517ef0a1fca1f58d644b" aria-controls="dtblockee32d08691a4517ef0a1fca1f58d644b" role="tab" data-toggle="tab" aria-expanded="true">Latest</a></li>
</ul>
<div class="tab-content">
 <div role="tabpanel" class="tab-pane animated fadeIn clearfix active" id="dtblockee32d08691a4517ef0a1fca1f58d644b">
<div class="">
<div id="dtblockee32d08691a4517ef0a1fca1f58d644bkkk">
<article class="widget-post clearfix post-231834 post type-post status-publish format-standard has-post-thumbnail hentry category-deals tag-giztop tag-xiaomi tag-xiaomi-redmi-note-7-buy tag-xiaomi-redmi-note-7-preorder tag-xiaomi-redmi-note-7-reease-date tag-xiaomi-redmi-note-7-specification tag-xiaomi-redmi-note-7-specs">
<div class="simple-thumb">
<a href="https://www.gizmochina.com/2019/01/11/the-xiaomi-redmi-note-7-is-now-accepting-pre-order-on-giztop/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/Xiaomi-Redmi-Note-7_featured-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /> </a>
</div>
<header>
<h3 class="h5">
<a href="https://www.gizmochina.com/2019/01/11/the-xiaomi-redmi-note-7-is-now-accepting-pre-order-on-giztop/">The Xiaomi Redmi Note 7 Is Now Accepting Pre-Order On Giztop</a>
</h3>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-11T01:43:00+00:00">5 days</time> ago</span></p> </header>
</article>
<article class="widget-post clearfix post-232559 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-16s tag-meizu-16s-plus tag-meizu-16t tag-snapdragon-855">
<div class="simple-thumb">
<a href="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/meizu-16s-render-featured-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="meizu-16s-render-featured" /> </a>
</div>
<header>
<h3 class="h5">
<a href="https://www.gizmochina.com/2019/01/16/meizu-16t-turbo-gaming-focused-phone-to-debut-with-meizu-16s-16s-plus-this-year/">Meizu 16T (Turbo) gaming-focused phone to debut with Meizu 16s, 16s Plus this year</a>
</h3>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-16T03:44:09+00:00">1 min</time> ago</span></p> </header>
</article>
<article class="widget-post clearfix post-232545 post type-post status-publish format-standard has-post-thumbnail hentry category-deals tag-chuwi tag-chuwi-lapbook-se-buy tag-chuwi-lapbook-se-laptop tag-chuwi-lapbook-se-price tag-chuwi-lapbook-se-specs tag-geekbuying">
<div class="simple-thumb">
<a href="https://www.gizmochina.com/2019/01/16/buy-chuwi-lapbook-se-laptop-for-just-268-99-on-geekbuying-coupon-inside/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/Chuwi-Lapbook-SE_featured-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /> </a>
</div>
<header>
<h3 class="h5">
<a href="https://www.gizmochina.com/2019/01/16/buy-chuwi-lapbook-se-laptop-for-just-268-99-on-geekbuying-coupon-inside/">Buy Chuwi Lapbook SE Laptop For Just $268.99 On GeekBuying [Coupon Inside]</a>
</h3>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-16T02:39:21+00:00">1 hour</time> ago</span></p> </header>
</article>
<article class="widget-post clearfix post-232546 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-sony tag-mwc-2019 tag-sony tag-xperia-l3 tag-xperia-xa3 tag-xperia-xa3-ultra tag-xperia-xz4 tag-xperia-xz4-compact">
<div class="simple-thumb">
<a href="https://www.gizmochina.com/2019/01/16/sony-confirms-mwc-2019-february-25-event-likely-to-debut-xperia-xz4-xa3-xa3-ultra-and-l3/">
<img src="https://www.gizmochina.com/wp-content/uploads/2019/01/XPERIA-XZ4-featured-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Sony-XPERIA-XZ4-featured" /> </a>
</div>
<header>
<h3 class="h5">
<a href="https://www.gizmochina.com/2019/01/16/sony-confirms-mwc-2019-february-25-event-likely-to-debut-xperia-xz4-xa3-xa3-ultra-and-l3/">Sony confirms MWC 2019 February 25 event; Likely to debut Xperia XZ4, XA3, XA3 Ultra and L3</a>
</h3>
<p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2019-01-16T02:29:33+00:00">1 hour</time> ago</span></p> </header>
</article></div>
</div>
</div>
</div>
</aside><aside id="boxed_widget-22" class="widget widget_boxed_widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1273706541600169" data-ad-slot="3645667989"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
<p></br></p>
<a href="https://bit.ly/2OuNdmM" target="_blank">
<img src="https://www.gizmochina.com/wp-content/uploads/2018/08/banggood-b0813.jpg" border="0" /></a></aside> </div>
</div>
</div>
</div>
</div>
<div class="mag-content clearfix">
<div class="row">
<div class="col-md-12">
<div class="content-bottom-wrapper"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display: block;" data-ad-client="ca-pub-1273706541600169" data-ad-slot="1180667344" data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
</div>
</div>

<footer class="footer source-org vcard copyright clearfix" id="footer">
<div class="footer-main">
<div class="fixed-main">
<div class="container">
<div class="mag-content">
<div class="row">
<div class="col-md-4">
<div id="text-16" class="footer-block clearfix widget_text"> <div class="textwidget"><p><img src="https://www.gizmochina.com/wp-content/uploads/2018/11/logo_footer_2018.png" alt="Gizmochina logo footer">
</p>
<p>
Gizmochina is a technical blog about products in China and subculture which includes smartphones, electronical gadgets, and everything else that comes under the genre.
<br />
</p></div>
</div><div id="social_widget-5" class="footer-block clearfix widget_social_widget"><ul class="social-list"><li class="social-facebook"><a href="https://www.facebook.com/gizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Facebook"><i class="fa fa-facebook"></i></a></li><li class="social-twitter"><a href="https://twitter.com/gizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Twitter"><i class="fa fa-twitter"></i></a></li><li class="social-google-plus"><a href="https://plus.google.com/106254210429868626292" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Google+"><i class="fa fa-google-plus"></i></a></li><li class="social-youtube"><a href="https://www.youtube.com/user/GizmoChinaTube" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Youtube"><i class="fa fa-youtube"></i></a></li><li class="social-vk"><a href="https://vk.com/rugizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="VK"><i class="fa fa-vk"></i></a></li></ul></div> </div>
<div class="col-md-2">
<div id="text-2" class="footer-block clearfix widget_text"><h3 class="footer-title">About</h3> <div class="textwidget"><ul>
<li><a href="https://www.gizmochina.com/about/">About us</a></li>
<li><a href="https://www.gizmochina.com/join-us/">Join the team</a></li>
<li><a href="https://www.gizmochina.com/privacy-policy/">Privacy policy</a></li>
<li><a href="https://www.gizmochina.com/terms-of-use/">Terms of use</a></li>
</ul></div>
</div> </div>
<div class="col-md-3">
<div id="text-17" class="footer-block clearfix widget_text"><h3 class="footer-title">Service</h3> <div class="textwidget"><ul>
<li><a href="https://www.gizmochina.com/adverts">Adverts</a></li>
<li><a href="https://www.gizmochina.com/post-a-deal/">Post a deal</a></li>
<li><a href="https://www.gizmochina.com/tips/">Send us a tip!</a></li>
<li><a href="https://www.gizmochina.com/contact-us/">Contact us</a></li>
</ul></div>
</div> </div>
<div class="col-md-3">
<div id="mc4wp_form_widget-3" class="footer-block clearfix widget_mc4wp_form_widget"><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-125161 mc4wp-form-basic" method="post" data-id="125161" data-name="Subscribe to Our Weekly Newsletter"><div class="mc4wp-form-fields"><p>
<label>Subscribe to Our Daily Newsletter.</label>
<input type="email" name="EMAIL" placeholder="Your email address" required />
</p>
<p>
<input type="submit" value="Subscribe" />
</p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1547610282" /><input type="hidden" name="_mc4wp_form_id" value="125161" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></div> </div>
</div> </div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="fixed-main">
<div class="container">
<div class="mag-content">
<div class="row">
<div class="col-md-6">
Copyright Gizmochina © 2018. All Rights Reserved </div>
<div class="col-md-6">
<div class="social-icons pull-right">
<a href="https://www.facebook.com/gizmochina" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/gizmochina" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter"></i></a><a href="https://www.youtube.com/user/GizmoChinaTube" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube"></i></a><a href="https://plus.google.com/106254210429868626292" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus"></i></a><a href="https://vk.com/rugizmochina" title="" data-original-title="VK" target="_blank"><i class="fa fa-vk"></i></a> </div>
</div>
</div> </div>
</div>
</div>
</div>
</footer>

</div>
<div class="mobile-overlay" id="mobile-overlay"></div>

<nav id="mobile-nav" class="mm-menu mm-offcanvas">
<div>
<ul id="menu-mobile-menu" class=""><li id="menu-item-122069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122069"><a href="https://www.gizmochina.com/news/">News</a></li>
<li id="menu-item-122070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122070"><a href="https://www.gizmochina.com/review/">Review</a></li>
<li id="menu-item-101708" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101708"><a href="https://www.gizmochina.com/phones/">Phones</a></li>
<li id="menu-item-122635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122635"><a href="https://www.gizmochina.com/giveaway/">Giveaway</a></li>
<li id="menu-item-117292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117292"><a href="https://www.gizmochina.com/deal/">Deals</a></li>
<li id="menu-item-76504" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76504"><a href="https://www.giztop.com" target="_blank">Shop</a></li>
<li id="menu-item-156715" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-156715"><a href="https://forum.gizmochina.com" target="_blank" rel="nofollow">Forums</a></li>
</ul> <div class="mobile-nav-footer">
<form role="search" method="get" class="search-form" action="https://www.gizmochina.com/">
<div class="input-group">
<span class="screen-reader-text">Search for:</span>
<input type="search" class="form-control" placeholder="Search &hellip;" value="" name="s" />
<span class="input-group-btn"><button type="submit" class="btn btn-default" value="Enter your search text...">
<i class="fa fa-search"></i></button></span></div></form> </div>
</div>
</nav>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-50975896-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-50975896-1');
</script>
<script type="text/javascript">
        var vanilla_forum_url = 'https://forum.gizmochina.com';
        (function() {
            var vanilla_count = document.createElement('script');
            vanilla_count.type = 'text/javascript';
            vanilla_count.src = vanilla_forum_url + '/js/count.js';
            (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(vanilla_count);
        })();
        </script>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.1.8"; } if (window.wp_blog_version === undefined) { window.wp_blog_version = "4.9.7"; } if (window.addthis_share === undefined) { window.addthis_share = {"url_transforms":{"shorten":{"twitter":"bitly"}},"shorteners":{"bitly":{}}}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ui_atversion":"300"}; } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.1.8","plugin_mode":"AddThis","anonymous_profile_id":"wp-acc8cf0c28848623fd0e0fa31a6a6ca7","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script><script type='text/javascript' src='https://s7.addthis.com/js/300/addthis_widget.js?ver=4.9.7#pubid=ra-5b5910aad5e4de56'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.gizmochina.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.0.3'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/themes/admag/css/plugins/bootstrap/js/bootstrap.min.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/themes/admag/js/plugins.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/themes/admag/js/script.js?ver=20130115'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/aps-products/js/nivo-lightbox.min.js?ver=2.5.3'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/aps-products/js/owl.carousel.min.js?ver=2.5.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aps_vars = {"ajaxurl":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","comp_link":"https:\/\/www.gizmochina.com\/compare\/","comp_cn":"aps_comp_69578151","show_panel":"1","comp_add":"Add to Compare","comp_rem":"Remove from Compare"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/aps-products/js/aps-main-script-min.js?ver=2.5.3'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=12.2'></script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.2.4'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.2.4'></script>
<![endif]-->
<div id="go-top-button" class="fa fa-angle-up" title="Scroll To Top"></div><script type="text/javascript">

      /* <![CDATA[ */

        jQuery(document).ready(function(){ });

      /* ]]> */

      </script></body>
</html>
