<!DOCTYPE html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.gizmochina.com/xmlrpc.php"><title>Meizu E2 Passes Through TENAA, Full Specifications Revealed - Gizmochina</title> <script rel="abtf">window.Abtf=function(window){var Abtf={cnf:{},h:function(cnf,css){this.cnf=cnf,cnf.proxy&&window.Abtf.proxy_setup(cnf.proxy),this.cnf.js&&!this.cnf.js[1]&&this.js(this.cnf.js[0]);var noref=!("undefined"==typeof this.cnf.noref||!this.cnf.noref);noref||this.ref(),"undefined"!=typeof cnf.gwf&&cnf.gwf[0]&&!cnf.gwf[1]&&("a"===cnf.gwf[0]?this.async(cnf.gwf[2],"webfont"):"undefined"!=typeof WebFont&&("string"==typeof cnf.gwf[0]&&(cnf.gwf[0]=eval("("+cnf.gwf[0]+")")),WebFont.load(cnf.gwf[0])))},f:function(a){a&&this.css&&this.css(),this.cnf.js&&this.cnf.js[1]&&this.js(this.cnf.js[0]),"undefined"!=typeof this.cnf.gwf&&this.cnf.gwf[0]&&this.cnf.gwf[1]&&("a"===this.cnf.gwf[0]?this.async(this.cnf.gwf[2],"webfont"):"undefined"!=typeof WebFont&&WebFont.load(this.cnf.gwf[0]))},ready:function(a,b,c){b=document,c="addEventListener",b[c]?b[c]("DocumentContentLoaded",a):window.attachEvent("onload",a)},ref:function(){"undefined"!=typeof window.console&&console.log("\n%c100","font: 1em sans-serif; color: white; background-color: #079c2d;padding:2px;","Google PageSpeed Score optimized using https://goo.gl/C1gw96\n\nTest your website: https://pagespeed.pro/tests\n\n")},async:function(a,b){!function(c){var d=c.createElement("script");d.src=a,b&&(d.id=b),d.async=!0;var e=c.getElementsByTagName("script")[0];if(e)e.parentNode.insertBefore(d,e);else{var f=document.head||document.getElementsByTagName("head")[0];f.appendChild(d)}}(document)}},SITE_URL,BASE_URL_REGEX;return Abtf}(window);!function(a,b){a.Abtf.css=function(){var a,b=this.cnf.css;if([[["all"],"https://www.gizmochina.com/wp-content/cache/autoptimize/css/autoptimize_30de498a2d607dab9131bf4d939f0c1f.css"],[["all"],"https://www.gizmochina.com/wp-content/cache/autoptimize/css/autoptimize_d3b43c68a26846a589042562406babcd.css"],[["all"],"https://www.gizmochina.com/wp-includes/css/dashicons.min.css?ver=4.7.4"]]!==b&&b){var c=!!document.getElementById("AbtfCSS")&&document.getElementById("AbtfCSS").nextSibling;for(i in b)"object"==typeof b[i]&&(a=b[i][0].join(","),this.loadCSS(b[i][1],c,a))}}}(window,window.Abtf);!function(a,b){a.Abtf.loadCSS=function(c,d,e,f){function g(a){return j.body?a():void setTimeout(function(){g(a)})}function h(){function a(){b.raf(function(){k.media=e||"all",f&&f()})}n||(n=!0,k.addEventListener&&k.removeEventListener("load",h),"undefined"!=typeof b.cnf.delay&&parseInt(b.cnf.delay)>0?setTimeout(a,b.cnf.delay):a())}var i,j=a.document,k=j.createElement("link");if(d)i=d;else{var l=(j.body||j.getElementsByTagName("head")[0]).childNodes;i=l[l.length-1]}var m=j.styleSheets;k.rel="stylesheet",k.href=c,k.media="only x",g(function(){i.parentNode.insertBefore(k,d?i:i.nextSibling)});var n=!1,o=function(a){if(!n){for(var b=k.href,c=m.length;c--&&!n;)if(m[c].href===b)return a();setTimeout(function(){o(a)})}};return k.addEventListener?k.addEventListener("load",h):k.onload=h,o(h),k},a.Abtf.raf=function(a){"function"==typeof requestAnimationFrame?requestAnimationFrame(a):"function"==typeof mozRequestAnimationFrame?mozRequestAnimationFrame(a):"function"==typeof webkitRequestAnimationFrame?webkitRequestAnimationFrame(a):"function"==typeof msRequestAnimationFrame?msRequestAnimationFrame(a):b.ready(a)}}(window,window.Abtf);Abtf.h({"css":[[["all"],"https://www.gizmochina.com/wp-content/cache/autoptimize/css/autoptimize_30de498a2d607dab9131bf4d939f0c1f.css"],[["all"],"https://www.gizmochina.com/wp-content/cache/autoptimize/css/autoptimize_d3b43c68a26846a589042562406babcd.css"],[["all"],"https://www.gizmochina.com/wp-includes/css/dashicons.min.css?ver=4.7.4"]],"delay":200});</script><style type="text/css" rel="abtf" id="AbtfCSS">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</style><link rel="canonical" href="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Meizu E2 Passes Through TENAA, Full Specifications Revealed - Gizmochina" /><meta property="og:description" content="The Meizu E2 has been spotted on China&#8217;s TENAA website after getting certified.  The mid-range phone is expected to be launched tomorrow at a Meizu event scheduled for 3:00 pm...." /><meta property="og:url" content="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/" /><meta property="og:site_name" content="Gizmochina" /><meta property="article:publisher" content="https://www.facebook.com/gizmochinablog" /><meta property="article:tag" content="Meizu" /><meta property="article:tag" content="Meizu E2" /><meta property="article:tag" content="Meizu E2 M714A" /><meta property="article:tag" content="Meizu E2 M714Y" /><meta property="article:tag" content="Meizu E2 specs" /><meta property="article:tag" content="TENAA" /><meta property="article:section" content="Meizu" /><meta property="article:published_time" content="2017-04-25T14:12:24+00:00" /><meta property="article:modified_time" content="2017-04-25T14:30:24+00:00" /><meta property="og:updated_time" content="2017-04-25T14:30:24+00:00" /><meta property="og:image" content="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg" /><meta property="og:image:width" content="480" /><meta property="og:image:height" content="640" /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Feed" href="https://www.gizmochina.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Comments Feed" href="https://www.gizmochina.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Gizmochina &raquo; Meizu E2 Passes Through TENAA, Full Specifications Revealed Comments Feed" href="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/feed/" /> <script type='text/javascript'>/*  */
var fvpdata = {"ajaxurl":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","nonce":"02caa76763","fitvids":"1","dynamic":"","overlay":"","opacity":"0.75","color":"b","width":"640"};
/*  */</script> <link rel='https://api.w.org/' href='https://www.gizmochina.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.gizmochina.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.gizmochina.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.7.4" /><link rel='shortlink' href='https://www.gizmochina.com/?p=128280' /><link rel="alternate" type="application/json+oembed" href="https://www.gizmochina.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.gizmochina.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F&#038;format=xml" /><link rel="canonical" href="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/" /><meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://www.gizmochina.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="https://www.gizmochina.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><link rel="shortcut icon" href="https://www.gizmochina.com/wp-content/uploads/2016/03/gizmochina-profile-2.png" type="image/x-icon" /><noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-128280 single-format-standard sticky-header wide wpb-js-composer js-comp-ver-4.8.0.1 vc_responsive"><div id="fb-root"></div><div id="main"><header class="header-wrapper clearfix"><div class="header" id="header"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-12"><a class="navbar-toggle collapsed" id="nav-button" href="#mobile-nav"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </a><nav class="navbar mega-menu"> <a class="logo" href="https://www.gizmochina.com/" title="Gizmochina - China Phones, Tablets , Gadgets News And Review" rel="home"> <img src="https://www.gizmochina.com/wp-content/uploads/2015/01/gizmochina-logo-new5.png" alt="Gizmochina" /> </a><div id="main-nav" class="collapse navbar-collapse"><ul id="menu-android" class="nav navbar-nav"><li id="menu-item-122067" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122067"><a href="https://www.gizmochina.com/news/">News</a></li><li id="menu-item-122068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122068"><a href="https://www.gizmochina.com/review/">Review</a></li><li id="menu-item-101707" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101707"><a href="https://www.gizmochina.com/phones/">Phones</a></li><li id="menu-item-122136" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122136"><a href="https://www.gizmochina.com/giveaway/">Giveaway</a></li><li id="menu-item-117279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117279"><a href="https://www.gizmochina.com/deal/">Deals</a></li><li id="menu-item-51841" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-51841"><a href="https://www.giztop.com/" target="_blank">Shop</a></li></ul></div><div class="header-right"><div class="social-icons"> <a href="https://www.facebook.com/gizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook fa-lg"></i></a><a href="https://twitter.com/gizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter fa-lg"></i></a><a href="https://www.youtube.com/user/GizmoChinaTube" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube fa-lg"></i></a><a href="https://plus.google.com/106254210429868626292" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus fa-lg"></i></a><a href="https://vk.com/rugizmochina" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="VK" target="_blank"><i class="fa fa-vk fa-lg"></i></a></div> <a href="#" class="fixed-button navbar-toggle" id="fixed-button"> <i></i> <i></i> <i></i> <i></i> </a></div><div id="sb-search" class="sb-search"><form action="https://www.gizmochina.com/" method="get"> <input class="sb-search-input" placeholder="Enter your search text..." type="text" value="" name="s" id="search"> <input class="sb-search-submit" type="submit" value=""> <input type="hidden" value="post" name="post_type" id="post_type" /> <span class="sb-icon-search fa fa-search" data-toggle="tooltip" data-placement="bottom" title="" data-original-title="Search"></span></form></div></nav></div></div></div></div></div></header><div id="content" class="site-content"><div class="container main-wrapper"><div class="mag-content clearfix"><div class="row"><div class="col-md-12"><div class="content-top-wrapper"><a href="http://blackview.hk/" target="_blank" rel="noopener noreferrer"><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/blackview-b0413.gif" alt="blackview deal" width="728" height="90" /></a></div></div></div></div><div class="main-content mag-content clearfix"><div class="row blog-content"><div class="col-md-8 main-wp dt_content"><div class="theiaStickySidebar"><div class="row"><div class="col-md-12"><article id="post-128280" class="dt_post_content clearfix post-128280 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-e2 tag-meizu-e2-m714a tag-meizu-e2-m714y tag-meizu-e2-specs tag-tenaa"><header class="post-header"><h1 class="post-title">Meizu E2 Passes Through TENAA, Full Specifications Revealed</h1><div class="cat-wrapper"><a href='https://www.gizmochina.com/category/meizu/' class='dt_cat bgcolor9'>Meizu</a><a href='https://www.gizmochina.com/category/news/' class='dt_cat bgcolor9'>News</a></div><p class="simple-share">by <span class="author vcard"><a class="url fn n" href="https://www.gizmochina.com/author/habeeb/"><b>Habeeb Onawole</b></a></span> <span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-25T14:12:24+00:00">23 mins</time> ago</span><span><i class="fa fa-eye"></i> </span><a class="comments-count" href="#comments">0</a></p></header><div class="post-content clearfix"><div class="nc_socialPanel swp_flatFresh swp_d_fullColor swp_i_fullColor swp_o_fullColor scale-100 scale-fullWidth" data-position="above" data-float="floatLeft" data-count="6" data-floatColor="#ffffff" data-emphasize="0"><div class="nc_tweetContainer swp_fb" data-id="4" data-network="facebook"><a rel="nofollow" target="_blank" href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-facebook"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer twitter" data-id="3" data-network="twitter"><a rel="nofollow" target="_blank" href="https://twitter.com/share?original_referer=/&text=Meizu+E2+Passes+Through+TENAA%2C+Full+Specifications+Revealed&url=https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/&via=gizmochina" data-link="https://twitter.com/share?original_referer=/&text=Meizu+E2+Passes+Through+TENAA%2C+Full+Specifications+Revealed&url=https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/&via=gizmochina" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-twitter"></i><span class="swp_share"> Tweet</span></span></span></span></a></div><div class="nc_tweetContainer googlePlus" data-id="2" data-network="google_plus"><a rel="nofollow" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-google-plus"></i><span class="swp_share"> +1</span></span></span></span></a></div><div class="nc_tweetContainer linkedIn" data-id="5" data-network="linked_in"><a rel="nofollow" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-linkedin"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer nc_pinterest" data-id="6" data-network="pinterest"><a rel="nofollow" onClick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);" class="nc_tweet noPop"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-pinterest"></i><span class="swp_share"> Pin</span></span></span></span></a></div><div class="nc_tweetContainer totes totesalt" data-id="7" ><span class="swp_count"><span class="swp_label">Shares</span> 0</span></div></div><p>The Meizu E2 has been spotted on China&#8217;s TENAA website after getting certified.  The mid-range phone is expected to be launched tomorrow at a Meizu event scheduled for 3:00 pm.</p><p>The highlight of the Meizu E2 is its unique LED flash which is integrated on the antenna line. The pictures provided so far show that the LEDs are more than two, but the exact number is not known. We counted four but some say there are 8 LEDs for the flash.</p><p><img class="aligncenter size-full wp-image-128282" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg" alt="Meizu E2 (M741A)" width="480" height="640" data-lazy-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg 480w, https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-225x300.jpg 225w" data-lazy-sizes="(max-width: 480px) 100vw, 480px" /><noscript><img class="aligncenter size-full wp-image-128282" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg" alt="Meizu E2 (M741A)" width="480" height="640" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg 480w, https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-225x300.jpg 225w" sizes="(max-width: 480px) 100vw, 480px" /></noscript></p><p>There are two models of the Meizu E2 ; one has model number <strong>M741A</strong> while the other&#8217; model number is <strong>M714Y</strong>. We want to believe the “A” and “Y” stands for Android and YunOS respectively even though the TENAA listing shows YunOS for both models.</p><p>There is a 5.5-inch FHD display on the E2, a 13MP rear camera and an 8MP for selfies. The phone will be available in three memory variants, so buyers are spoilt for choice here. There ia 2GB+16GB version, a 3GB+32GB model, and a 4GB+64GB version. All three will be powered by an octa-core processor clocked at 2.35GHz. We still don&#8217;t know what chip it is but we presume it might be the Helio P20 or Helio P25 chipset. The three versions also support storage expansion via the MicroSD card slot (max. 128GB).</p><p style="text-align: center"><span style="color: #ff0000">READ MORE:</span> <a href="https://www.gizmochina.com/2017/04/06/new-meizu-m612c-phone-shows-tenaa/">New  Meizu M612C Phone Shows Up At TENAA</a><span id="more-128280"></span></p><p>Under the metal back plate of the Meizu E2 is a 3300mAh battery with support for 18W fast charging. The dimensions are 153.7×75.7×7.5(mm) and weight is 165g. It will be available in black, silver and gold and will be priced at ¥1699 (¬$247). Initial response to the $250 price when it leaked wasn&#8217;t positive but now that we know there is a 4GB RAM version, we want to believe that it is the one with that price tag.</p><p>(<a href="http://shouji.tenaa.com.cn/Mobile/MobileDetail.aspx?code=XSRnDagtFCtz2nKfUjx5bdcBuP1FQVa6" target="_blank" rel="nofollow">Source</a>)</p><div id="envira-gallery-wrap-128291" class="envira-gallery-wrap envira-gallery-theme-base envira-lightbox-theme-base_dark" itemscope itemtype="http://schema.org/ImageGallery"><div style="opacity: 0.0"  data-row-height="150" data-justified-margins="1" data-gallery-theme="normal" id="envira-gallery-128291" class="envira-gallery-public envira-gallery-justified-public envira-gallery-0-columns envira-clear envira-gallery-css-animations" data-envira-columns="0"><div id="envira-gallery-item-128284" class="envira-gallery-item enviratope-item envira-gallery-item-1" style="padding-left: 5px; padding-bottom: 10px; padding-right: 5px;"  itemscope itemtype="http://schema.org/ImageObject"><div class="envira-gallery-item-inner"><div class="envira-gallery-position-overlay  envira-gallery-top-left"></div><div class="envira-gallery-position-overlay  envira-gallery-top-right"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-left"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-right"></div><a  href="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A.jpg" class="envira-gallery-128291 envira-gallery-link " rel="enviragallery128291" title="Meizu E2 (M741A)" data-envira-caption="" data-envira-retina="" data-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-150x100_c.jpg" data-mobile-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-150x100_c.jpg"  itemprop="contentUrl" ><img id="envira-gallery-image-128284" class="envira-gallery-image envira-lazy envira-gallery-image-1 envira-normal" data-envira-index="1" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-640x480.jpg" data-envira-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-640x480.jpg" data-envira-gallery-id="128291" data-envira-item-id="128284" data-envira-caption="Meizu E2 (M741A) - " alt="Meizu E2 (M741A)" title="Meizu E2 (M741A)"  data-no-lazy="1"  itemprop="thumbnailUrl" data-envira-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-1280x960.jpg 2x" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-1280x960.jpg 2x" /></a></div></div><div id="envira-gallery-item-128283" class="envira-gallery-item enviratope-item envira-gallery-item-2" style="padding-left: 5px; padding-bottom: 10px; padding-right: 5px;"  itemscope itemtype="http://schema.org/ImageObject"><div class="envira-gallery-item-inner"><div class="envira-gallery-position-overlay  envira-gallery-top-left"></div><div class="envira-gallery-position-overlay  envira-gallery-top-right"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-left"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-right"></div><a  href="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b.jpg" class="envira-gallery-128291 envira-gallery-link " rel="enviragallery128291" title="Meizu E2 (M741A)" data-envira-caption="" data-envira-retina="" data-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-150x100_c.jpg" data-mobile-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-150x100_c.jpg"  itemprop="contentUrl" ><img id="envira-gallery-image-128283" class="envira-gallery-image envira-lazy envira-gallery-image-2 envira-normal" data-envira-index="2" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-640x480.jpg" data-envira-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-640x480.jpg" data-envira-gallery-id="128291" data-envira-item-id="128283" data-envira-caption="Meizu E2 (M741A) - " alt="Meizu E2 (M741A)" title="Meizu E2 (M741A)"  data-no-lazy="1"  itemprop="thumbnailUrl" data-envira-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-1280x960.jpg 2x" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b-1280x960.jpg 2x" /></a></div></div><div id="envira-gallery-item-128282" class="envira-gallery-item enviratope-item envira-gallery-item-3" style="padding-left: 5px; padding-bottom: 10px; padding-right: 5px;"  itemscope itemtype="http://schema.org/ImageObject"><div class="envira-gallery-item-inner"><div class="envira-gallery-position-overlay  envira-gallery-top-left"></div><div class="envira-gallery-position-overlay  envira-gallery-top-right"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-left"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-right"></div><a  href="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg" class="envira-gallery-128291 envira-gallery-link " rel="enviragallery128291" title="Meizu E2 (M741A) c" data-envira-caption="" data-envira-retina="" data-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-150x100_c.jpg" data-mobile-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-150x100_c.jpg"  itemprop="contentUrl" ><img id="envira-gallery-image-128282" class="envira-gallery-image envira-lazy envira-gallery-image-3 envira-normal" data-envira-index="3" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-640x480.jpg" data-envira-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-640x480.jpg" data-envira-gallery-id="128291" data-envira-item-id="128282" data-envira-caption="Meizu E2 (M741A) c - " alt="Meizu E2 (M741A)" title="Meizu E2 (M741A) c"  data-no-lazy="1"  itemprop="thumbnailUrl" data-envira-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-1280x960.jpg 2x" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-640x480.jpg 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-1280x960.jpg 2x" /></a></div></div><div id="envira-gallery-item-128286" class="envira-gallery-item enviratope-item envira-gallery-item-4" style="padding-left: 5px; padding-bottom: 10px; padding-right: 5px;"  itemscope itemtype="http://schema.org/ImageObject"><div class="envira-gallery-item-inner"><div class="envira-gallery-position-overlay  envira-gallery-top-left"></div><div class="envira-gallery-position-overlay  envira-gallery-top-right"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-left"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-right"></div><a  href="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d.png" class="envira-gallery-128291 envira-gallery-link " rel="enviragallery128291" title="Meizu E2 (M741A) d" data-envira-caption="" data-envira-retina="" data-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-150x100_c.png" data-mobile-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-150x100_c.png"  itemprop="contentUrl" ><img id="envira-gallery-image-128286" class="envira-gallery-image envira-lazy envira-gallery-image-4 envira-normal" data-envira-index="4" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-640x480.png" data-envira-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-640x480.png" data-envira-gallery-id="128291" data-envira-item-id="128286" data-envira-caption="Meizu E2 (M741A) d - " alt="Meizu E2 (M741A)" title="Meizu E2 (M741A) d"  data-no-lazy="1"  itemprop="thumbnailUrl" data-envira-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-640x480.png 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-1280x960.png 2x" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-640x480.png 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d-1280x960.png 2x" /></a></div></div><div id="envira-gallery-item-128285" class="envira-gallery-item enviratope-item envira-gallery-item-5" style="padding-left: 5px; padding-bottom: 10px; padding-right: 5px;"  itemscope itemtype="http://schema.org/ImageObject"><div class="envira-gallery-item-inner"><div class="envira-gallery-position-overlay  envira-gallery-top-left"></div><div class="envira-gallery-position-overlay  envira-gallery-top-right"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-left"></div><div class="envira-gallery-position-overlay  envira-gallery-bottom-right"></div><a  href="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e.png" class="envira-gallery-128291 envira-gallery-link " rel="enviragallery128291" title="Meizu E2 (M741A) e" data-envira-caption="" data-envira-retina="" data-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-150x100_c.png" data-mobile-thumbnail="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-150x100_c.png"  itemprop="contentUrl" ><img id="envira-gallery-image-128285" class="envira-gallery-image envira-lazy envira-gallery-image-5 envira-normal" data-envira-index="5" src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-724x1024-640x480.png" data-envira-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-724x1024-640x480.png" data-envira-gallery-id="128291" data-envira-item-id="128285" data-envira-caption="Meizu E2 (M741A) e - " alt="Meizu E2 (M741A)" title="Meizu E2 (M741A) e"  data-no-lazy="1"  itemprop="thumbnailUrl" data-envira-srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-724x1024-640x480.png 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-1280x960.png 2x" srcset="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-724x1024-640x480.png 1x,https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e-1280x960.png 2x" /></a></div></div></div></div><noscript><img data-no-lazy="1"  src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A.jpg" alt="Meizu E2 (M741A)" /><img data-no-lazy="1"  src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-b.jpg" alt="Meizu E2 (M741A)" /><img data-no-lazy="1"  src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c.jpg" alt="Meizu E2 (M741A)" /><img data-no-lazy="1"  src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-d.png" alt="Meizu E2 (M741A)" /><img data-no-lazy="1"  src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-e.png" alt="Meizu E2 (M741A)" /></noscript> Always be the first to know. Follow us:<ul class="smbt-social-icons"><li> <a href="https://www.facebook.com/gizmochina"  title="Facebook" target="blank"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/facebook.png" alt="Facebook" /><noscript><img src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/facebook.png" alt="Facebook" /></noscript> </a></li><li> <a href="https://twitter.com/gizmochina"  title="Twitter" target="blank"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/twitter.png" alt="Twitter" /><noscript><img src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/twitter.png" alt="Twitter" /></noscript> </a></li><li> <a href="https://www.youtube.com/user/gizmochinatube"  title="YouTube" target="blank"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/youtube.png" alt="YouTube" /><noscript><img src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/youtube.png" alt="YouTube" /></noscript> </a></li><li> <a href="https://vk.com/rugizmochina"  title="VKontakte" target="blank"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/vkontakte.png" alt="VKontakte" /><noscript><img src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/vkontakte.png" alt="VKontakte" /></noscript> </a></li><li> <a href="https://www.gizmochina.com/feed"  title="RSS Feed" target="blank"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/rss-feed.png" alt="RSS Feed" /><noscript><img src="https://www.gizmochina.com/wp-content/plugins/social-media-buttons-toolbar/inc/img/social-media-icons/rss-feed.png" alt="RSS Feed" /></noscript> </a></li></ul><div class="swp-content-locator"></div></div><footer class="post-meta"><div class="tags-wrapper"><ul class="tags-widget clearfix"><li class="trending">Tags:</li><li><a href="https://www.gizmochina.com/tag/meizu/" rel="tag">Meizu</a></li><li><a href="https://www.gizmochina.com/tag/meizu-e2/" rel="tag">Meizu E2</a></li><li><a href="https://www.gizmochina.com/tag/meizu-e2-m714a/" rel="tag">Meizu E2 M714A</a></li><li><a href="https://www.gizmochina.com/tag/meizu-e2-m714y/" rel="tag">Meizu E2 M714Y</a></li><li><a href="https://www.gizmochina.com/tag/meizu-e2-specs/" rel="tag">Meizu E2 specs</a></li><li><a href="https://www.gizmochina.com/tag/tenaa/" rel="tag">TENAA</a></li></ul></div><div class="author-box clearfix"><div class="author-avatar"> <a href="https://www.gizmochina.com/author/habeeb/"> <img alt='' src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src='https://secure.gravatar.com/avatar/16b9d3ca71efaabe3975d8c5cd669397?s=110&#038;d=mm&#038;r=g' data-lazy-srcset='https://secure.gravatar.com/avatar/16b9d3ca71efaabe3975d8c5cd669397?s=220&amp;d=mm&amp;r=g 2x' class='avatar avatar-110 photo' height='110' width='110' /><noscript><img alt='' src='https://secure.gravatar.com/avatar/16b9d3ca71efaabe3975d8c5cd669397?s=110&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/16b9d3ca71efaabe3975d8c5cd669397?s=220&amp;d=mm&amp;r=g 2x' class='avatar avatar-110 photo' height='110' width='110' /></noscript> </a></div><div class="author-info"><h3><a href="https://www.gizmochina.com/author/habeeb/">Habeeb Onawole</a></h3><p class="author-position">Writer</p><p>I breathe tech! Want to get me to talk about something else? Then try movies. You can follow me on Twitter @habeebpain.</p><div class="author-contact"> <a href="http://habeebpain" target="_blank"><i class="fa fa-twitter fa-lg" title="Twitter"></i></a><a href="http://www.linkedin.com/in/habeeb-onawole-884" target="_blank"><i class="fa fa-linkedin fa-lg" title="Linkedin"></i></a></div></div></div><div class="row"><div class="post-nav-wrapper clearfix"><div class="col-md-6 omega"><div class="previous-post"><div class="post-nav-label"> <i class="fa fa-angle-left"></i> Previous post</div> <a href="https://www.gizmochina.com/2017/04/25/leeco-le-max-2-models-flash-sale-tomtop/">LeEco Le Max 2 models Flash Sale on TomTop</a></div></div><div class="col-md-6 alpha"></div></div></div></footer><div class="content-mid-wrapper clearfix"><a href="https://goo.gl/MbWf8k" target="_blank" rel="noopener noreferrer"><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/chuwu-b0422.jpg" alt="Buy Chuwi Surbook" width="728" height="90" /></a></div><div class="related-posts clearfix"><h3 class="block-title"><span>Related posts</span></h3><div class="row "><div class="col-md-4"><article class="small-article post-128017 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-e2 tag-meizu-e2-camera tag-meizu-e2-specs"><figure class="feed-image"> <a href="https://www.gizmochina.com/2017/04/24/leaked-meizu-e2-press-image-of-meizu-e2-shows-led-flash-integrated-on-the-antenna-line/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-Press-Image-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="Meizu E2 Press Image" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-Press-Image-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="Meizu E2 Press Image" /></noscript> </a></figure><h6> <a href="https://www.gizmochina.com/2017/04/24/leaked-meizu-e2-press-image-of-meizu-e2-shows-led-flash-integrated-on-the-antenna-line/"> Leaked Meizu E2 Press Image Shows LED Flash Intgrated on The Antenna Line </a></h6><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-24T07:51:05+00:00">1 day</time> ago</span></p></article></div><div class="col-md-4"><article class="small-article post-127846 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-e2 tag-meizu-e2-camera tag-meizu-e2-flash tag-meizu-e2-price tag-meizu-e2-specs"><figure class="feed-image"> <a href="https://www.gizmochina.com/2017/04/21/meizu-e2-rear-photo-appears-reveals-new-camera-design/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/meizu-e2-image-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="meizu e2" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/meizu-e2-image-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="meizu e2" /></noscript> </a></figure><h6> <a href="https://www.gizmochina.com/2017/04/21/meizu-e2-rear-photo-appears-reveals-new-camera-design/"> Entirely Different Meizu E2 Rear Photo Appears, Reveals New Camera Design </a></h6><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-21T10:06:08+00:00">4 days</time> ago</span></p></article></div><div class="col-md-4"><article class="small-article post-127820 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-e2 tag-meizu-e2-price tag-meizu-e2-specs"><figure class="feed-image"> <a href="https://www.gizmochina.com/2017/04/21/meizu-e2-price-specs-leak-new-image-no-dual-cameras-too/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/meizu-e2-real-2-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="meizu e2" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/meizu-e2-real-2-540x355.jpg" class="attachment-modern_medium_thumb size-modern_medium_thumb wp-post-image" alt="meizu e2" /></noscript> </a></figure><h6> <a href="https://www.gizmochina.com/2017/04/21/meizu-e2-price-specs-leak-new-image-no-dual-cameras-too/"> Meizu E2 Price and Specs Leak in New Image, No Dual Cameras Too </a></h6><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-21T04:59:11+00:00">4 days</time> ago</span></p></article></div></div></div><div id="disqus_thread"></div></article></div></div></div></div><div class="col-md-4 dt_sidebar"><div class="widget-area" role="complementary"><div class="theiaStickySidebar"><aside id="aps_search-5" class="widget aps_search"><h3 class="block-title"><span>Phone Finder</span></h3><form class="aps-search-form" method="get" action="https://www.gizmochina.com"><div class="aps-search-field"> <input type="hidden" name="post_type" value="aps-products" /> <input type="text" name="s" class="aps-search" value="" /> <span class="aps-icon-search aps-search-btn"></span></div></form></aside><aside id="boxed_widget-4" class="widget widget_boxed_widget"><div align=center><a href="https://goo.gl/hgjLRc" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2017/03/leagoo-b0323.gif" style="width: 300px; height: 250px;"/></a></div><p></br></p><div align=center><a href="https://www.giztop.com/xiaomi-mi6.html" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/mi6-banner.jpg" style="width: 300px; height: 480px;"/></a></div></aside><aside id="tabs_widget-2" class="widget widget_tabs_widget"><ul class="nav nav-tabs" role="tablist" id="widget-tab"><li role="presentation" class="active"><a href="#dtblock478cae50a523c38f5c5f259c1570112b" aria-controls="dtblock478cae50a523c38f5c5f259c1570112b" role="tab" data-toggle="tab" aria-expanded="true">Latest</a></li></ul><div class="tab-content"><div role="tabpanel" class="tab-pane animated fadeIn clearfix active" id="dtblock478cae50a523c38f5c5f259c1570112b"><div class=""><div id="dtblock478cae50a523c38f5c5f259c1570112bkkk"><article class="widget-post clearfix post-127795 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-top"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/20/xiaomi-mi-6-now-available-pre-order-giztop/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/bg-mi6-1-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="xioami mi 6" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/bg-mi6-1-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="xioami mi 6" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/20/xiaomi-mi-6-now-available-pre-order-giztop/">Xiaomi Mi 6 Is Now Available for Pre-order on Giztop</a></h3><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-20T18:42:27+00:00">5 days</time> ago</span></p></header></article><article class="widget-post clearfix post-128280 post type-post status-publish format-standard has-post-thumbnail hentry category-meizu category-news tag-meizu tag-meizu-e2 tag-meizu-e2-m714a tag-meizu-e2-m714y tag-meizu-e2-specs tag-tenaa"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Meizu E2 (M741A)" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/Meizu-E2-M741A-c-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Meizu E2 (M741A)" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/">Meizu E2 Passes Through TENAA, Full Specifications Revealed</a></h3><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-25T14:12:24+00:00">23 mins</time> ago</span></p></header></article><article class="widget-post clearfix post-128273 post type-post status-publish format-standard has-post-thumbnail hentry category-deals category-leeco category-tomtop tag-128gb-storage tag-2k-display tag-6gb-ram tag-deal tag-discount tag-flash-sale tag-gold tag-le-max-2 tag-leeco tag-offer tag-ois tag-silver tag-tomtop"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/25/leeco-le-max-2-models-flash-sale-tomtop/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Le-Max-2-1-e1493126485467-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Le Max 2" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/Le-Max-2-1-e1493126485467-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Le Max 2" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/25/leeco-le-max-2-models-flash-sale-tomtop/">LeEco Le Max 2 models Flash Sale on TomTop</a></h3><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-25T13:23:07+00:00">1 hour</time> ago</span></p></header></article><article class="widget-post clearfix post-128270 post type-post status-publish format-standard has-post-thumbnail hentry category-banggood category-deals tag-banggood tag-big-discounts tag-car-accessories tag-coupons tag-deals tag-electronics tag-offers tag-travel tag-wearables"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/25/banggood-saving-offers-get-big-discounts-everyday/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Banggood-95x80.png" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Banggood" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/Banggood-95x80.png" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Banggood" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/25/banggood-saving-offers-get-big-discounts-everyday/">Banggood Saving and Offers: Get Big Discounts Everyday</a></h3><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-25T12:58:29+00:00">2 hours</time> ago</span></p></header></article><article class="widget-post clearfix post-128264 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-samsung tag-galaxy-s8 tag-galaxy-s8-wireless-charging-issue tag-samsung"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/25/galaxy-s8-s8-wireless-charging-problem-minor-glitch-intentional-move-samsung/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/Galaxy-S8-S8-Wireless-Charging-Issue-95x80.png" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Galaxy S8, Galaxy S8+ Wireless Charging Issue" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/Galaxy-S8-S8-Wireless-Charging-Issue-95x80.png" class="attachment-text_thumb size-text_thumb wp-post-image" alt="Galaxy S8, Galaxy S8+ Wireless Charging Issue" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/25/galaxy-s8-s8-wireless-charging-problem-minor-glitch-intentional-move-samsung/">Galaxy S8, S8+ Wireless Charging Problem: Minor Glitch or Intentional Move from Samsung?</a></h3><p class="simple-share"><span class="article-date"><i class="fa fa-clock-o"></i> <time class="entry-date published updated" datetime="2017-04-25T11:22:15+00:00">3 hours</time> ago</span></p></header></article></div></div></div></div></aside><aside id="boxed_widget-7" class="widget widget_boxed_widget"><div align=center><a href="https://goo.gl/KhwqQK" target="_blank"><img src="https://www.gizmochina.com/wp-content/uploads/2017/03/mgcool-b0328.jpg" style="width: 300px; height: 250px;"/></a></div><p></br></p> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1273706541600169"
data-ad-slot="3425593994"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></aside><aside id="reviews_widget-2" class="widget widget_reviews_widget"><h3 class="block-title"><span>Reviews</span></h3><div class="widget_rev_wrapper"><article class="widget-post clearfix post-127795 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-news category-top"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/20/xiaomi-mi-6-now-available-pre-order-giztop/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/bg-mi6-1-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="xioami mi 6" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/bg-mi6-1-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="xioami mi 6" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/20/xiaomi-mi-6-now-available-pre-order-giztop/">Xiaomi Mi 6 Is Now Available for Pre-order on Giztop</a></h3><p class="simple-share"></p></header></article><article class="widget-post clearfix post-127505 post type-post status-publish format-standard has-post-thumbnail hentry category-center category-review tag-ulefone-power-2 tag-ulefone-power-2-review tag-ulefone-smartphone"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/19/ulefone-power-2-review-another-battery-monster/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1100316JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1100316JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/19/ulefone-power-2-review-another-battery-monster/">Ulefone Power 2 Review &#8211; Another Battery Monster!</a></h3><p class="simple-share"><span class="star-reviews"><i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star-half-o"></i> </span></p></header></article><article class="widget-post clearfix post-125472 post type-post status-publish format-standard has-post-thumbnail hentry category-center category-review tag-cheap-smartphones-2017 tag-cubot-rainbow-2 tag-cubot-rainbow-2-camera-review tag-cubot-rainbow-2-dual-camera tag-cubot-rainbow-2-review"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/05/cubot-rainbow-2-review/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1090712JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="cubot rainbow 2" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1090712JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="cubot rainbow 2" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/05/cubot-rainbow-2-review/">Cubot Rainbow 2 Review &#8211; Dual Cameras for $70!</a></h3><p class="simple-share"><span class="star-reviews"><i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star-o"></i> </span></p></header></article><article class="widget-post clearfix post-125177 post type-post status-publish format-standard has-post-thumbnail hentry category-center category-lenovo category-review tag-best-affordable-smartphones-2017 tag-best-budget-phone-2017 tag-best-budget-smartphones-2017 tag-best-phone-under-250 tag-best-phone-under-300 tag-g5-review tag-lenovo-moto-g5 tag-lenovo-moto-g5-review tag-moto-g-2017 tag-moto-g-review-2017 tag-moto-g5 tag-moto-g5-benchmarks tag-moto-g5-camera-review tag-moto-g5-india tag-moto-g5-plus-review tag-moto-g5-review tag-motorola-moto-g5 tag-motorola-moto-g5-review tag-techlinehd tag-top-5-budget-phones-2017 tag-top-5-cheap-smartphones-2017"><div class="simple-thumb"> <a href="https://www.gizmochina.com/2017/04/03/lenovo-moto-g5-review-budget-smartphone-king-back/"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1090760JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2017/04/P1090760JPG-95x80.jpg" class="attachment-text_thumb size-text_thumb wp-post-image" alt="" /></noscript> </a></div><header><h3 class="h5"> <a href="https://www.gizmochina.com/2017/04/03/lenovo-moto-g5-review-budget-smartphone-king-back/">Lenovo Moto G5 Review &#8211; The Budget Smartphone King is Back?</a></h3><p class="simple-share"><span class="star-reviews"><i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star"></i> <i class="fa fa-star-half-o"></i> </span></p></header></article></div></aside><aside id="boxed_widget-8" class="widget widget_boxed_widget"><a href="http://shrsl.com/?hh1h" target="_blank"> <img src="https://www.gizmochina.com/wp-content/uploads/2017/04/banggood-b0418.jpg" border="0"/></a><p></br></p> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:300px;height:250px"
data-ad-client="ca-pub-1273706541600169"
data-ad-slot="3425593994"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></aside><aside id="facebook_widget-2" class="widget widget_facebook_widget"><h3 class="block-title"><span>Follow us on Facebook</span></h3><div style="height:160px; overflow:hidden;"><div class="fb-page" data-href="https://www.facebook.com/gizmochina" data-width="350" data-height="160" data-small-header="true" data-adapt-container-width="false" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"></div></div></div></aside></div></div></div></div></div><div class="mag-content clearfix"><div class="row"><div class="col-md-12"><div class="content-bottom-wrapper"><script src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js" async=""></script>  <ins class="adsbygoogle" style="display: block;" hidden="" data-ad-client="ca-pub-1273706541600169" data-ad-slot="8961619997" data-ad-format="auto"></ins> <script>//  (adsbygoogle = window.adsbygoogle || []).push({}); //</script></div></div></div></div></div></div><footer class="footer source-org vcard copyright clearfix" id="footer"><div class="footer-main"><div class="fixed-main"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-4"><div id="text-16" class="footer-block clearfix widget_text"><div class="textwidget"><p><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://www.gizmochina.com/wp-content/uploads/2015/01/gizmochina-logo-new5.png" alt="Gizmochina logo" width="159"><noscript><img src="https://www.gizmochina.com/wp-content/uploads/2015/01/gizmochina-logo-new5.png" alt="Gizmochina logo" width="159"></noscript></p><p> GizmoChina is a technical blog about products in China and subculture which includes smartphones, electronical gadgets, and everything else that comes under the genre. <br/></p></div></div><div id="social_widget-5" class="footer-block clearfix widget_social_widget"><ul class="social-list"><li class="social-facebook"><a href="https://www.facebook.com/gizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Facebook"><i class="fa fa-facebook"></i></a></li><li class="social-twitter"><a href="https://twitter.com/gizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Twitter"><i class="fa fa-twitter"></i></a></li><li class="social-google-plus"><a href="https://plus.google.com/106254210429868626292" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Google+"><i class="fa fa-google-plus"></i></a></li><li class="social-youtube"><a href="https://www.youtube.com/user/GizmoChinaTube" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="Youtube"><i class="fa fa-youtube"></i></a></li><li class="social-vk"><a href="https://vk.com/rugizmochina" data-toggle="tooltip" target="_blank" data-placement="bottom" title="" data-original-title="VK"><i class="fa fa-vk"></i></a></li></ul></div></div><div class="col-md-2"><div id="text-2" class="footer-block clearfix widget_text"><h3 class="footer-title">About</h3><div class="textwidget"><ul><li><a href="https://www.gizmochina.com/about/">About US</a></li><li><a href="https://www.gizmochina.com/adverts">Post Advertise</a></li><li><a href="https://www.gizmochina.com/join-us/">Join the Team</a></li><li><a href="https://www.gizmochina.com/contact-us/">Contact us</a></li></ul></div></div></div><div class="col-md-3"><div id="text-17" class="footer-block clearfix widget_text"><h3 class="footer-title">Languages</h3><div class="textwidget"><ul><li><a href="https://www.gizmochina.com/">English</a></li><li><a href="https://ru.gizmochina.com/">Russian</a></li><li><a href="https://it.gizmochina.com/">Italian</a></li></ul></div></div></div><div class="col-md-3"><div id="mc4wp_form_widget-3" class="footer-block clearfix widget_mc4wp_form_widget"><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-125161" method="post" data-id="125161" data-name="Sign up for our newsletter" ><div class="mc4wp-form-fields"><p> <label>Sign up for our AWESOME Weekly Newsletter!</label> <input type="email" name="EMAIL" placeholder="Your email address" required /></p><p> <input type="submit" value="Subscribe" /></p><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></div><input type="hidden" name="_mc4wp_timestamp" value="1493130922" /><input type="hidden" name="_mc4wp_form_id" value="125161" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2" /></div><div class="mc4wp-response"></div></form></div></div></div></div></div></div></div><div class="footer-bottom"><div class="fixed-main"><div class="container"><div class="mag-content"><div class="row"><div class="col-md-6"> Copyright Gizmochina © 2017. All Rights Reserved</div><div class="col-md-6"><div class="social-icons pull-right"> <a href="https://www.facebook.com/gizmochina" title="" data-original-title="Facebook" target="_blank"><i class="fa fa-facebook"></i></a><a href="https://twitter.com/gizmochina" title="" data-original-title="Twitter" target="_blank"><i class="fa fa-twitter"></i></a><a href="https://www.youtube.com/user/GizmoChinaTube" title="" data-original-title="Youtube" target="_blank"><i class="fa fa-youtube"></i></a><a href="https://plus.google.com/106254210429868626292" title="" data-original-title="Google+" target="_blank"><i class="fa fa-google-plus"></i></a><a href="https://vk.com/rugizmochina" title="" data-original-title="VK" target="_blank"><i class="fa fa-vk"></i></a></div></div></div></div></div></div></div></footer></div><div class="mobile-overlay" id="mobile-overlay"></div><nav id="mobile-nav" class="mm-menu mm-offcanvas"><div><ul id="menu-mobile-menu" class=""><li id="menu-item-122069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122069"><a href="https://www.gizmochina.com/news/">News</a></li><li id="menu-item-122070" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122070"><a href="https://www.gizmochina.com/review/">Review</a></li><li id="menu-item-101708" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-101708"><a href="https://www.gizmochina.com/phones/">Phones</a></li><li id="menu-item-122635" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-122635"><a href="https://www.gizmochina.com/giveaway/">Giveaway</a></li><li id="menu-item-117292" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-117292"><a href="https://www.gizmochina.com/deal/">Deals</a></li><li id="menu-item-76504" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76504"><a href="https://www.giztop.com" target="_blank">Shop</a></li></ul><div class="mobile-nav-footer"><form role="search" method="get" class="search-form" action="https://www.gizmochina.com/"><div class="input-group"> <span class="screen-reader-text">Search for:</span> <input type="search" class="form-control" placeholder="Search &hellip;" value="" name="s" /> <span class="input-group-btn"><button type="submit" class="btn btn-default" value="Enter your search text..." > <i class="fa fa-search"></i></button></span></div></form></div></div></nav><div class="nc_socialPanelSide nc_socialPanel swp_default swp_d_fullColor swp_i_fullColor swp_o_fullColor slide" data-position="above" data-float="floatLeft" data-count="6" data-floatColor="#ffffff" data-screen-width="1100" data-transition="slide" data-mobileFloat="off"><div class="nc_tweetContainer totes totesalt" data-id="6" ><span class="swp_count">0</span><span class="swp_label"> Shares</span></div><div class="nc_tweetContainer swp_fb" data-id="4" data-network="facebook"><a rel="nofollow" target="_blank" href="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="http://www.facebook.com/share.php?u=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-facebook"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer twitter" data-id="3" data-network="twitter"><a rel="nofollow" target="_blank" href="https://twitter.com/share?original_referer=/&text=Meizu+E2+Passes+Through+TENAA%2C+Full+Specifications+Revealed&url=https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/&via=gizmochina" data-link="https://twitter.com/share?original_referer=/&text=Meizu+E2+Passes+Through+TENAA%2C+Full+Specifications+Revealed&url=https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/&via=gizmochina" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-twitter"></i><span class="swp_share"> Tweet</span></span></span></span></a></div><div class="nc_tweetContainer googlePlus" data-id="2" data-network="google_plus"><a rel="nofollow" target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="https://plus.google.com/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-google-plus"></i><span class="swp_share"> +1</span></span></span></span></a></div><div class="nc_tweetContainer linkedIn" data-id="5" data-network="linked_in"><a rel="nofollow" target="_blank" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" data-link="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.gizmochina.com%2F2017%2F04%2F25%2Fmeizu-e2-passes-tenaa-full-specifications-revealed%2F" class="nc_tweet"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-linkedin"></i><span class="swp_share"> Share</span></span></span></span></a></div><div class="nc_tweetContainer nc_pinterest" data-id="6" data-network="pinterest"><a rel="nofollow" onClick="var e=document.createElement('script');e.setAttribute('type','text/javascript');e.setAttribute('charset','UTF-8');e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e);" class="nc_tweet noPop"><span class="swp_count swp_hide"><span class="iconFiller"><span class="spaceManWilly"><i class="sw sw-pinterest"></i><span class="swp_share"> Pin</span></span></span></span></a></div></div> <script type='text/javascript'>/*  */
var viewsCacheL10n = {"admin_ajax_url":"https:\/\/www.gizmochina.com\/wp-admin\/admin-ajax.php","post_id":"128280"};
/*  */</script> <script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.4'></script> <!--[if lte IE 9]> <script type='text/javascript' src='https://www.gizmochina.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.0'></script> <![endif]--> <script rel="abtf">Abtf.f(true);</script><script type="text/javascript">var swpClickTracking = false; var swp_nonce = "b92846346e";		swp_admin_ajax = 'https://www.gizmochina.com/wp-admin/admin-ajax.php';
		var swp_buttons_exist = !!document.getElementsByClassName( 'nc_socialPanel' );
		if ( swp_buttons_exist ) {
			jQuery( document ).ready( function() {
				var swp_cache_data = {
					'action': 'swp_cache_trigger',
					'post_id': 128280				};
				jQuery.post( swp_admin_ajax, swp_cache_data, function( response ) {
					console.log(response);
				});
			});
			swp_post_id='128280';
			swp_post_url='https://www.gizmochina.com/2017/04/25/meizu-e2-passes-tenaa-full-specifications-revealed/';
			swp_post_recovery_url = '';
			socialWarfarePlugin.fetchShares();
		}</script><div id="go-top-button" class="fa fa-angle-up" title="Scroll To Top"></div> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-50975896-1', 'auto');
  ga('send', 'pageview');</script> <script type="text/javascript" defer src="https://www.gizmochina.com/wp-content/cache/autoptimize/js/autoptimize_76d3326c9fbc7830418283730a05a59a.js"></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1493130922 -->